Pascal Learning Curve

What I’ve learned so far:

  • I spent a while trying graphics libraries (or failing to even compile them) before deciding I don’t understand the UI model enough yet, so I’ll prototype with some high-level drawing and circle back around to OpenGL or SDL.
  • Build a do-nothing app in Lazarus, make a single form with a default FormCreate method, then quit out and write code starting from there in BBEdit.
    • Part of that is that I’m not going to use a ton of GUI components, and code building is the evil opposite of Interface Builder. In IB, you edit UI and connect it to method names scanned out of the source code, it doesn’t touch your code.
    • The Lazarus editor is nightmarishly wrong and keeps inserting stuff in my code which makes me crazy. Maybe there’s non-crazy-making settings, and probably it seems fine to masochistic Windows and Linux users, but I make enough problems in my life.
  • Naming conflicts are a giant problem, so my current naming scheme is: For class “foo”, it goes in file FooUnit.pas, containing unit FooUnit and type TFoo = class…. I’m naming instance fields _bar and accessors bar() and setBar() as I do in most languages. I’ve mostly got the compiler to stop screaming at me every build. Not letting you name a unit, class, and field the same thing is infuriating.
  • Build with lazbuild -B --bm=Release whatever.lpi; I wrote a script to choose Debug or Release builds and launch the app if nothing went wrong, which is close enough to hitting Cmd-R.
  • Bookmark the docs for:
    • RunTime Library
    • Free Component Library – in particular unit ‘contnrs’ wants to buy some vowels but has dictionaries, lists, etc.
    • Lazarus Class Library
    • There’s very little explanation, so often I have to go digging in source like /Developer/lazarus/lcl. I lost about 30 minutes today because they didn’t document that TCanvas.FillRect uses Brush settings, TCanvas.Rectangle uses Pen settings, and I figured it out by reading the Carbon implementation. 😡 ☕️ 🔪
  • Almost always if there’s a non-domain-specific type I need it already exists. Batteries are included but mostly they’re named badly, or upside down, or hidden in sofa cushions, or the dog buried them and I need a metal detector, or my psycho ex stole them and is holding them hostage for a pity fuck.
  • The actual implementation code isn’t much different from any other procedural language. For a guy who codes in Pascal for one year every 10 years, it’s rolling along pretty fast. The near-equivalency of records and classes, and of functions, properties, and methods is convenient. Defining vars before using them, like in old-timey K&R C, is not convenient. Inline variable definition would be a gigantic quality of life improvement, which I doubt they’ll do.